Sega Cd wont turn on.

User Tag List

Results 1 to 4 of 4
  1. Sega Cd wont turn on.

    08-24-2009, 08:35 AM
    I went to play my Sega CD today and it would not turn on. The main unit worked but the CD unit just sat there. So I tried my gen 1 sega with it, nothing, cleaned the contacts on both, nothing. So I thought it was strange that boom it just stoped working so maybe there is a fuse. So I looked up sega cd fuse and yup there is one, but it is a strange diode looking thing.

    I hard wired the connections between the fuse and boom it worked. The fuse is a Pico II 2.5A which is at for about $5 for 5 of them. I was just going to wire/solder up an inline fuse holder so if this happens again it will be easy to replace. I guess if you leave the Sega CD plugged in for a long time the fuse can pop,or if you use an nes power supply. The 10v power supply I guess is the proper one for the Sega CD. There is a video on youtube for this fix.


    I just went the solder in a fuse route. ITS ALIVE! ITS ALIVE!!!!!!!

    The old F301 fuse in the pic is to blame.
    Ryan Fenton
    # of Fbombs because WiiMote did not register motion properly
  2. Re: Sega Cd wont turn on.

    08-24-2009, 09:32 AM
    Glad you were able to breathe new life into the system. Thanks for sharing the how to information as well.
    Nik Meeks
    Chattanooga, TN
  3. 01-05-2016, 07:19 PM
    I bought a broken one off of eBay in a lot and was hoping it was the fuse. $5 at Radio Shack brought it back to life. Loving my SegaCd now. Glad you had success too.
    Likes Aergan liked this post
  4. 01-25-2016, 05:29 AM
    Took me two years and 2x Mega-CD mk1 units to fully repair mine. First one had blown capacitors on the mainboard and a shorted (dead) Samsung KM6264BLG-10 (Save RAM) with previous signs of mis-repair. Luckily, the rest of the unit was fine but no Save RAM which stops games like Sonic CD from booting.
    2nd unit was dead with blown caps & fuse on the power board. This was quickly repaired but the lens unit had begun to fair from power related issues. My guess was that someone tried to adjust the pots and over powered it trying to get it to read before the power board failed. A copy of Arcade Classics was in the drive still.
    Thankfully, the mainboard was in great condition so I was able to use it in my original mk1. I've been running a fully working unit now for the last 6 months and it's my pride & joy.
Join us