Bug reporting thread

  1. 06-17-2020, 12:07 PM
    Quote Originally Posted by GibGirl View Post
    I notice I can see his scores on his profile page, but clicking on his name on a track leaderboard goes to the score list page and not his profile? Not sure where that needs to be fixed, or does it fix itself later on?
    That is a general bug. Thanks for pointing that out.
    I've added it to the list.
    Thanks GibGirl thanked this post
  2. 06-18-2020, 07:34 AM
    A small complaint--hope this is the right place.

    When editing message text, you cannot select text and type a character to replace it. Only the Backspace and/or Delete keys are allowable input when any text is selected.

    I attempt to do this a lot, as I'm an inveterate quibbler when it comes to word selection. Thanks for your efforts.
  3. 06-18-2020, 11:29 AM
    Quote Originally Posted by grinder2112 View Post
    A small complaint--hope this is the right place.

    When editing message text, you cannot select text and type a character to replace it. Only the Backspace and/or Delete keys are allowable input when any text is selected.

    I attempt to do this a lot, as I'm an inveterate quibbler when it comes to word selection. Thanks for your efforts.
    Hmmm, I don't seem to have this issue, nor has it come up before.
    Can you please record a video the next time this happens to you?

    Have you you tried pressing the "Insert" key on your keyboard?
  4. 06-19-2020, 03:54 AM
    Quote Originally Posted by grinder2112 View Post
    A small complaint--hope this is the right place.

    When editing message text, you cannot select text and type a character to replace it. Only the Backspace and/or Delete keys are allowable input when any text is selected.
    I can confirm this, as the same thing happened to me at least twice during some small correction.

    There is also this peculiar window popup "Do you want to leave this site" or something similar. It happens when I change pages or press the "back" key on my mouse.

    Franny, I have more work for you:). I've seen this mistake as long as I can remember: Omega Race date on high scores page shows 1983. For a while I thought it was the date it was added to database, but Canyon Bomber shows correctly 1978. The correct date for Omega Race is 1981. This is especially crucial these days, as next year will be the 40th anniversary of this game.
    This is the page:
    https://www.twingalaxies.com/scores.php?player=43902 (notice the light background (I'm using dark theme otherwise)).

    What's strange the new format of the page doesn't even show the date at all:
    https://www.twingalaxies.com/game/om...-men-to-start/

    It seems that both systems are still not fully combined.

    Of course arcade version for 1 and 2 credits has the date "1983" as well:
    https://www.twingalaxies.com/scores.php?player=11599

    This probably was entered by mistake, as in 1983 home versions of this game came out.

    Just noticed this while pasting links. After the scores merger to my account, yes, the scores show in my profile, but the high score board above still shows "player=43902" while my User ID is 25133. This could cause problems later down the road.

    Thanks in advance!
  5. 06-19-2020, 04:20 AM
    I also noticed this some years back:
    https://www.twingalaxies.com/scores.php?player=11812

    This user's name is Tom Gault. Could it be the same Thomas Gault? He was also just active in the 1980s.

    What's also peculiar on this page: Bubble Bobble shows as 1991 ... strange as it came out in 1986 and there are scores listed there since 1986 as well:
    https://www.twingalaxies.com/game/bu...s-normal-mode/

    Also, QBert is listed as 1998???

    Note: I can confirm the page doesn't allow to type over a word. I just highlighted one and tried to type over it, but nothing happened. I had to press Backspace to erase the word, but then the cursor took a hike from the edit window and I had to use a mouse to click in the desired spot again.
    Last edited by omega175; 06-19-2020 at 04:25 AM.
  6. 06-20-2020, 07:17 PM
    Quote Originally Posted by SincerelyFranny View Post
    Hmmm, I don't seem to have this issue, nor has it come up before.
    Can you please record a video the next time this happens to you?

    I'm afraid I don't have a virtual keyboard to reflect the keystrokes in the video, but it's always the same: Typing a most characters will not replace text. It appears that BACKSPACE, DELETE, UP, DOWN, LEFT, RIGHT and RETURN function as expected, but nothing for an alphanumeric.

    Have you you tried pressing the "Insert" key on your keyboard?

    Insert or overwrite mode makes no difference.

    Aha! Another essential element, apparently, is that the selection must be made by double-clicking on a word. I do that so routinely, I had not even tried it with a click and drag selection.
  7. 06-20-2020, 07:28 PM
    Quote Originally Posted by grinder2112 View Post
    I'm afraid I don't have a virtual keyboard to reflect the keystrokes in the video, but it's always the same: Typing a most characters will not replace text. It appears that BACKSPACE, DELETE, UP, DOWN, LEFT, RIGHT and RETURN function as expected, but nothing for an alphanumeric.




    Insert or overwrite mode makes no difference.

    Aha! Another essential element, apparently, is that the selection must be made by double-clicking on a word. I do that so routinely, I had not even tried it with a click and drag selection.

    Is this what you mean isn't happening for you?

    Name:  e.gif
Views: 22
Size:  1.14 MB

    What browser are you on?
  8. 06-20-2020, 07:44 PM
    Google Chrome. Try double-clicking a word to select it, rather than making a dragging selection.
  9. 06-20-2020, 08:26 PM
    Quote Originally Posted by grinder2112 View Post
    Google Chrome. Try double-clicking a word to select it, rather than making a dragging selection.

    Ah, I see.

    I'll add that to the list. Until then, the click and drag will have to be your work around.
    Thanks grinder2112 thanked this post
  10. 06-25-2020, 07:29 AM
    When a score is removed due to a dispute being accepted, the "records" count for that track - and by extension, that game - does not get adjusted. As a result, if a number of scores are removed from a track/game, the records count can be significantly different than the actual number of scores.

    For example - https://www.twingalaxies.com/game/de...0/atari-jaguar.

    The game shows as having 11 records. If you go into it, you see a track that lists 5 records, but only has 2 scores. And then two tracks stating 3 records each, but with no scores at all.

    This also results in the games page, when it lists games, sorting by record count incorrectly, as the counts themselves are off.
    Join the UNOFFICIAL Twin Galaxies Discord: https://discordapp.com/invite/7PfNNDk
    Thanks SincerelyFranny thanked this post
Page 4 of 4 FirstFirst ... 2 3 4
Results 31 to 40 of 40
Page 4 of 4 FirstFirst ... 2 3 4
Join us