recording through Obs studio driving me crazy

  1. recording through Obs studio driving me crazy

    01-08-2021, 04:43 PM
    Hi guys,

    hate to be a pain as you'd think I'd know these things by now but for the life of me can't get OBS to record wolfmame successfully. Keeps dropping out with fatal errors like "too many live textures" and "Unable to complete window creation". I successfully did once before after a TG member guided me through the steps but can't find that message. I think window capture was the preferred capture method but wolfmame doesn't always come up as being available. Scoured the interwebs and TG forums and couldn't find any help on the matter so if someone can provide the steps and best config I'll be sure to save this time.

    Thanks

    Lindsay
  2. 01-10-2021, 09:09 AM
    ive used OBS studio to capture, but recently swapped to Stream labs OBS. I've been able to capture most things from there.

    Have you tried Stream labs OBS? Or is there a specific reason that your using OBS Studio?
  3. 01-10-2021, 11:09 PM
    no havent tried Stream Labs Obs so will give that a crack. When asked best way to convert inp file to video was advice Obs studio was the way.

    Thanks in advance anything I need to know about Stream Labs settings wise?
  4. Yesterday, 02:23 AM
    is this an error on the obs itself or the emu ur running? if it's obs I think u need to run it as admin. If it's the emu, it might be conflicting with obs for that you need to submit a report on the devs so they could see whats happening.
  5. Yesterday, 03:03 PM
    Hi Danny,

    the error is produced by emu but I am also unable to get in OBS. Streamlabs OBS had same outcome Bandicam. Fraps has worked without a hitch just need to compress the file. Would have preferred to use OBS and will give try again in future. What EMU and OBS are you running and is there any order that you start them up and settings you use in OBS? I'm on wolfmame 0.183 and OBS Studio. Where do I get t

    Thanks for the advice and where do I retrieve an error report?


    Lindsay
  6. Today, 09:34 AM
    Agree with you!
  7. Today, 01:55 PM
    I always use "Display Capture" as my Source because OBS has a hard time finding the MAME window/game you want to record. I think this is because of the way MAME loads up the frontend/gui first and then loads the game you want to play after that. OBS sees these as two different windows/games and usually won't recognize the playback until you load it from MAME first.

    To even see the gameplay as an option you usually need to load MAME first, then start the game, pause it, go back to Windows (via ALT+ENTER) and then go back to OBS or load it then to see if it can see the window/game now which is pretty silly. Even if you manage to get OBS to recognize the right window/game it will often forget that relationship if you come back and try to record the same thing again (after closing OBS).

    To get around this I just use Display Capture and run MAME full screen for recordings. Right click in the Sources box (or click +). Remove any non-working/unnecessary sources first. Then Add "Display Capture". Also make sure you have at least one "Scene" in the Scenes box.

    At the Create/Select Source box you can name your display and make sure to check "Make Source Visible" then click OK.

    Then from the Properties box you can select from the available Displays which show the Windows screen # first then current resolution that you should see in the preview above. Below the preview of the current Display you have to left click the tab or the arrows on the right side of it to see other available monitors/displays. You can also check whether or not to capture the cursor in recordings just below here.

    If OBS is on the same Display that is being previewed it will show a weird infinite mirrored screen effect but don't worry it won't record like that. I usually have it set up with OBS on my laptop Display 1 and capture the MAME playback from Display 2 /my second monitor (that should be what you see is what you get in the preview).

    After you have everything setup the way you want click OK and you will be back at the main OBS screen where it should still be showing the correct preview Display output above all the options. If not (blank screen) you can right click on the source you just created and adjust the Properties again until you get it working.

    If you are still having issues even with Display Capture try going to Settings/Output (if blank preview still). If the Output Mode is still at the default Simple view you can try changing the Streaming/Recording Encoder settings here to see if that fixes the problem. There is usually at least a Software (x264) and a Hardware option for your video card so try a different one and see if that works or not. I usually use the Hardware (NVENC) for my Nvidia card (for both streaming/recording). If the Output Mode is set to Advanced it's basically the same thing but you have to click on the separate Streaming/Recording tabs first to see the all Encoder options for each type.

    This is also where you can setup the Recording Path to save to on your computer, the Recording Quality (which affects file sizes), and the Recording Format (FLV, MP4, MPG, MKV, MOV etc.).

    There is some good info about most of the basic OBS options at the link below...
    https://echoshare.co/best-obs-recording-settings-bitrate-1080p-format/


    Last edited by jerky; Today at 02:24 PM.
  8. Today, 02:21 PM
    When I run from the command line OBS doesn't have the issue of recognizing the window since there's only one called MAME but I also run MAME in window mode. Running full screen I imagine the display capture is as valid and convenient of a setup as any other.
Results 1 to 8 of 8
Join us