M.A.M.E. - Qix [set 1] - Points - 59,726 - Roger Edwin Blair 111

Is this Performance Claim Valid?

    This poll is closed
This poll is closed
  1. M.A.M.E. - Qix [set 1] - Points - 59,726 - Roger Edwin Blair 111

    06-04-2021, 09:14 AM
    vzaar-player


    Points
    WolfMame version
    183
    Track
    https://www.twingalaxies.com/scores.php?scores=5221
    Rank

    Rules
    ROMSet: qix
    Internal Defaults
    -----------------
    Number of Turns: 3
    Threshold: 75
    Time Line: 37
    Difficulty 1: 1
    Difficulty 2: 1
    Difficulty 3: 1
    Difficulty 4: 1
    Table Mode: 0
    Special Rules: The above are the default internal settings for this title and need not be changed.
    Submission Message

    Wolfmame 183.
    NOTE!
    I'm "pretty sure" this is right. Might not be a bad idea to wait to vote until some of the Pro's chime in, tbh.
    There's an issue with deleting NVRAM on some games(Ironic, huh, Pete?), as it screws up the playback of the inp.
    Well, the NVRAM DOES do something on this game, it holds the high score, but mostly-when you very first start the game, you have to press F3 to select "English". Well, that also is programmed in MAME to stop recording an input, lol.
    Pretty sure every stinking key on the keyboard is programmed to something in MAME, kinda too lazy to find an unused key and remap, figure all that out, BUT-
    Regardless, the NVRAM doesn't affect the playback or anything.
    Also-when playing back an inp to record it, if you delete the NVRAM, it wants you to select English again, and stops playback.
    So plz let me know-I can prolly do better on this, but just checking before I go farther, as to whether I am playing fair or not.
    Thanks Everyone!!!

    Attached Files Attached Files
    Likes wwdkong, Ulisses Patriota, nads liked this post
  2. 06-05-2021, 03:29 AM
    Mr Poco, you have violated the sacred prohibition against NVRAM.

    The penalty is death.

    Death of this submission, anyway.

    Next game you play, disable the NVRAM; start the machine; press '9' a few times, to exit settings.

    At no point is it necessary to press 'F3'. Do the above, and you'll be able to record an INP without NVRAM.
    Thanks Rogerpoco thanked this post
    Likes Rogerpoco, nads liked this post
  3. 06-05-2021, 03:58 AM
    Quote Originally Posted by Almighty Dreadlock View Post
    Mr Poco, you have violated the sacred prohibition against NVRAM.

    The penalty is death.

    Death of this submission, anyway.

    Next game you play, disable the NVRAM; start the machine; press '9' a few times, to exit settings.

    At no point is it necessary to press 'F3'. Do the above, and you'll be able to record an INP without NVRAM.
    Ah, gotcha, gave that a try, TBH...thinking mebbe you were wrong about pressing 9-I should have known better, worked like a charm.
    OK, good deal-I KNEW there might be an issue there, I just couldn't find the right workaround.
    Thanks, I'll get a proper one in soon!!!

    So, Please, "No" votes on this one!
    So they say
    Dance for me, dance for me, dance for me, oh, oh, oh
    Thanks nads, evan04 thanked this post
    Likes Ulisses Patriota liked this post
  4. 06-05-2021, 04:08 AM
    Quote Originally Posted by Almighty Dreadlock View Post
    Mr Poco, you have violated the sacred prohibition against NVRAM.

    The penalty is death.

    Death of this submission, anyway.

    Next game you play, disable the NVRAM; start the machine; press '9' a few times, to exit settings.

    At no point is it necessary to press 'F3'. Do the above, and you'll be able to record an INP without NVRAM.
    Hey-how do I disable the NVRAM?
    I remember, I think, Ben talking about it once, mebbe typing a "Nul" in the cfg file or something, but I think I tried and couldn't get it to disable?
    Thanks!!!
    So they say
    Dance for me, dance for me, dance for me, oh, oh, oh
  5. 06-05-2021, 04:31 AM
    Quote Originally Posted by Rogerpoco View Post
    Hey-how do I disable the NVRAM?

    If you use a command line or batch file, include:-

    -nvram_directory NUL.

    If not, edit Wolf MAME's initiation file. Open 'mame.ini', and look for this section:-

    Click image for larger version. 

Name:	image.png 
Views:	31 
Size:	8.9 KB 
ID:	128219

    I don't know, off the top of my head, what to do. Probably enough to just delete "nvram". Alternatively, replace it with '0'. Or delete the whole line. Something will work, I'm sure.
    Thanks Rogerpoco, evan04, wwdkong thanked this post
    Likes nads, Rogerpoco liked this post
  6. 06-05-2021, 04:55 AM
    Quote Originally Posted by Almighty Dreadlock View Post
    If you use a command line or batch file, include:-

    -nvram_directory NUL.

    If not, edit Wolf MAME's initiation file. Open 'mame.ini', and look for this section:-

    Click image for larger version. 

Name:	image.png 
Views:	31 
Size:	8.9 KB 
ID:	128219

    I don't know, off the top of my head, what to do. Probably enough to just delete "nvram". Alternatively, replace it with '0'. Or delete the whole line. Something will work, I'm sure.
    NBD, but I can't get it to work- "0" does keep it from creating an NVRAM file, BUT the game acts as if it has active NVRAM still, remembers it's English.
    When I put "nul", MAME just started acting weird, couldn't start properly, but started.
    I'll just manually delete them every game I guess.
    Seems like the same trouble when I tried to disable the NVRAM before.
    183, no command lines, BTW, that's a bit over my head, I use the GUI.
    :P
    So they say
    Dance for me, dance for me, dance for me, oh, oh, oh
    Thanks Almighty Dreadlock thanked this post
  7. 06-05-2021, 05:52 AM
    Quote Originally Posted by Rogerpoco View Post
    "0" does keep it from creating an NVRAM file, BUT the game acts as if it has active NVRAM still, remembers it's English.

    That sounds like a good result, to me. The machine's going with the default setting, and not prompting you to change anything, is that right?
    Thanks Rogerpoco thanked this post
    Likes Rogerpoco liked this post
  8. 06-05-2021, 06:04 AM
    Quote Originally Posted by Almighty Dreadlock View Post
    That sounds like a good result, to me. The machine's going with the default setting, and not prompting you to change anything, is that right?
    That seems correct, yes!
    Well, Ok.
    Truly-I know it seems straightforward but I really do struggle to get the MAME stuff right, and I certainly appreciate the help!!!
    So they say
    Dance for me, dance for me, dance for me, oh, oh, oh
  9. 06-05-2021, 06:23 AM
    Quote Originally Posted by Almighty Dreadlock View Post
    That sounds like a good result, to me. The machine's going with the default setting, and not prompting you to change anything, is that right?
    OK, when I changed the ini to "0", what happened was that it made a folder named "0", and started storing the nvram there, lol!
    I'm just gonna delete the things manually, I DO remember struggling with this in the past.
    So they say
    Dance for me, dance for me, dance for me, oh, oh, oh
  10. 06-05-2021, 06:29 AM
    Quote Originally Posted by Rogerpoco View Post
    OK, when I changed the ini to "0", what happened was that it made a folder named "0", and started storing the nvram there

    Follow my first suggestion, then. Delete "nvram", and don't put anything in its place. The space after "nvram_directory" should be blank. Try that, let me know what happens.
    Thanks Rogerpoco thanked this post
    Likes Rogerpoco liked this post
Page 1 of 2 12 LastLast
Results 1 to 10 of 15
Page 1 of 2 12 LastLast
Join us